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Focus:
"= MQ8&DP 7.5

Topics:

= Queue Manager Object
MQ Front Side Handler
MQ URL

Message Headers

Error Handling
Transaction Management
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Queue Manager Object
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Queue Manager Object

ﬁ Configure MQ Queue Manager

This configuration has been added and not yet saved.
Main LConnactions LCoT MOQCSE
MQ Queue Manager:DEVQMGR [up]

[ Apely | [cancel | [ Delete | [Undo | Export | View Log | View Status | Help

General Configuration

Administrative State @ enabled () disabled

Comments
Host Name [192.168.153.1(1416) |*
Queue Manager Name | DEVQMGR
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Queue Manager Object

= Host Name (IPv4)

> address:port 192.168.57.1:1414
> address(port) 192.168.57.1(1414)
> address 192.168.57.1 default port 1414

= Host Name (IPv6)

» [address]:port [2202::1148:248]:1414
> address(port) 2202::148:248(1414)
» address 2202::148:248 default port 1414

= Host Name (DNS)

» hostname:port myserver:1414
» hostname(port) myserver(1414)
» hostname myserver default port 1414
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Queue Manager Object

ﬁ Configure MQ Queue Manager

This configuration has been added and not yet saved,

Main Connactions £osr Mocsp

MQ Queue ManagEr:DEVQMGR [up]

[apply | [ Cancel | [ Delete | [ Undy | Export | View Log | View Status | Help

General Configuration

Administrative State i@ enabled () disabled

Comments
Host Name \92.168.153.1(1416) |*
Queue Manager Name DEVQMGR
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Queue Manager Object

Channel Name

.DEF.SVRCONN

Channel Heartbeat

30_0 , seconds
User Nams
Alternate User » on ) off
XML Manager | default i |-+ | *
Maximum Message Size 1048576 bytes
Cache Timeout seconds
Units of Work and Backout
Units of Work I |
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Queue Manager Object

= Channel Name
» SVRCONN name as defined on the Queue Manager

= Channel Heartbeat (seconds)

» Approximate time between heartbeat flows on the channel

» 0 = no heartbeat flow exchanged

» Does not set the heartbeat on the channel

» Negotiates heartbeat value with channel definition -- greater is used

= Cache Timeout (seconds)

» How long the appliance keeps alive a dynamic connection in the connection cache
» Must be greater than the negotiated heartbeat interval but less than the Queue
Manager keep alive interval (defined on the host)
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Queue Manager Object

= User Name
» Supplied to Queue Manager at connection
» Maximum 12 characters

= Alternate User
» Enables or disables MQOD.AlternateUserld
» Off = use Message Descriptor User Identifier for queue authorization

» On (default) = use Object Descriptor Alternate User Identifier for queue authorization
(need to create Object Descriptor)

= XML Manager
» Recommend using a dedicated XML Manager per QM object
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Queue Manager Object

= Maximum Message Size
» Limit the size of the MQ message payload

= Units of Work
» Controls syncpoint processing (transaction management)
» Affects MQ Front Side Handlers only
» Two values: 0 or 1

= Units of Work =0
» No syncpoint control
» Front Side Handler MQGET is immediate and irrevocable
» If error, message integrity is responsibility of DataPower
= Units of Work =1
» Enables syncpoint control
» Front Side Handler MQGET has an implied MQGMO_SYNCPOINT
» If error, message is rolled back via implied MQBACK
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Queue Manager — Connections Tab

Open Connections

Total Connection Limit 250
Initial Connections 1

Local Address

Retry Behavior

Automatic Retry ® on off

Retry Interval 1 seconds
Retry Attempts 0 attempts
Long Retry Interval '_ 1800 seconds
Reporting Interval |1 | seconds

Conversation Sharing

Sharing Conversations o

T —

Capitalware's MQ Technical Conference v2.0.1.6




Queue Manager — Connections Tab

= Total Connection Limit:
» Connection pool size of the QM object
» Default value is 250
» Can tune the total connection limit for performance

= |nitial Connections:
» Maximum simultaneous initial connection requests
» Default value is 1
» If too high, may flood the Queue Manager

= | ocal Address
» Local address for outbound connections
» Specific local interface and port
» For a range of ports, use (1414,1420) or x.x.x.x(1414,1420)
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Queue Manager — Connections Tab

= Automatic Retry
» On: Attempt to reconnect to the Queue Manager if connection dropped
» Off: Disable and re-enable the Queue Manager object to reconnect

= Retry Interval
» Time interval between attempts to retry failed connections
» Recommend 10 to 15 seconds (default is 1 second)
> Low value can spike CPU and memory usage

= Retry Attempts
» Number of attempts to retry the failed connections
> After threshold reached, the Long Retry Interval is used instead
» Default value of 0 (zero) disables Long Retry Interval
» Recommend non-zero value

T —
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Queue Manager — Connections Tab

= Long Retry Interval
» Interval in seconds to retry connection after Retry Attempts
» Recommend 600 seconds (default is 1800)
» Must be greater than the Retry Interval (if less, ignored)

= Reporting Interval
» How often to log retries (seconds)
» Suppresses duplicate log entries
» Recommend setting this the same as Retry Interval
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Queue Manager — Connections Tab

= Sharing Conversations
» Maximum conversations sharing single TCP/IP connection

» Value is negotiated between SVRCONN SHARECNYV setting and DataPower (lower
value takes effect)

» Value of 0 means NO Shared Conversations

e Suppresses MQ V7+ features (Administrator stop-quiesce; Heartbeating; Read
ahead; Client asynchronous consume)

» Value of 1 means NO Shared Conversations

* Allows MQ V7+ features (Administrator stop-quiesce; Heartbeating; Read ahead;
Client asynchronous consume)

» Value > 1 means Shared Conversations permitted

* Allows MQ V7+ features (Administrator stop-quiesce; Heartbeating; Read ahead;
Client asynchronous consume)

» Can impact performance of clients (unless V7+ features used)
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Queue Manager — Connections Tab

Security

Secure communication with the remote queue manager in one of two ways. If both, SSL client profile takes precedence.

= With an SSL client profile: Specify the SSL client profile. Must use this method for IBM MQ for 2/05.
= With artifacts from GSKit: Specify the SSL key repository and cipher specification.

SSL client type Praxy Profile ¥ SSL client type [ Client Profile ¥ |
SEL Proxy Profile (deprecated) [{none) ¥ =| +I | SSL client profile [{none) ¥ I 7 |_|
SSL Key Repository certy/// v

| (none) ¥ |.U|:|Ioa.;:.l... | Fetch... |

Permit S5L v3 an s off

SEL Cipher Specification [Nane v
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Queue Manager — Connections Tab

= SSL Client Type: Client Profile
> Select the SSL Client Profile object to use from the pick list
» Must be used for connection to a z/OS host

= SSL Client Type: Proxy Profile
» Deprecated — recommend using Client Profile instead
» Select the SSL Proxy Profile object to use from the pick list

= SSL Key Repository
> Select the location of the key database file

= SSL Version 3 Support
» Permit SSL v3 or not

= SSL Cipher Specification
» Choose the Cipher Spec to use

T —
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Client Profile Object

Capitalware's MQ Technical Conference v2.0.1.6

Client Profile — Main Tab

Protocols

Ciphers

Features

Use custom SNI Hostname

Enable SSL version 3
'#! Enable TLS version 1.0
¥ Enable TLS version 1.1
¥ Enable TLS version 1.2

ECDHE_ECDSA_WITH_AES_256_GCM_SHA3S4 i R -

ECDHE _RSA_WITH_AES_256_GCM_SHA3Z84 ¢ i+ X

ECDHE_ECDSA_WITH_AES_256_CBC_SHA384 1r i+ X

ECDHE_RSA_WITH_AES_256_CBC_SHA384 T R

ECDHE_ECDSA_WITH_AES_256_CBC_SHA . =
v |[add]

¥ Use snI
! Permit connections to insecure SSL servers
| Enable compression

R

Credential

Identification credentials

Validate server certificate

Validation credentials

[tnone) ¥ [+ [ ]*
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Client Profile — Main Tab

= Protocols:
» Choose the protocols to be supported

= Ciphers:
» Choose the ciphers to be supported | Vs custem St Hostnzme [yesv]*
= Use SNI: Custam SNI hastname s

» Send the Server Name Indication (SNI) TLS extension in the client hello message
= Permit connections to insecure SSL servers:
» Allow connection to potentially vulnerable servers
= Enable compression:
> Allow SSL compression
» Not recommended — can allow CRIME or BREACH attacks
= |dentification credentials:
» If mutual authentication requested by server
= Validate server certificate:
> Check the credentials presented by the server (Default: On)
= Validation credentials:
» Crypto Validation Credential object used for server certificate validation
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Client Profile — Session Caching Tab

Main Session Caching Advanced

SSL Client Profile

| Apply || Cancel |

Name | %

Enable session caching & on o off

Session cache timeout 300 seconds
Session cache size [ 100 | entries

T —
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Client Profile — Session Caching Tab

= Enable session caching:
» Allow SSL session caching

= Session Cache Timeout:
» How long before cache is flushed
» Maximum: 86,400 seconds (24 hours)

= Session Cache Size:
» How many entries to be cached
» Maximum: 500,000
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Client Profile — Advanced Tab

Session Caching Advanced

i

SSL Client Profile

S
| apply || cancel |

Name | | ¥
Elliptic Curves secp521rl - NIST/SECG curve over a 521 bit prime field P
secp384rl - NIST/SECG curve over a 384 bit prime field @ {} 4
secp256kl - SECG curve over a 256 bit prime field [
secp236rl - NIST/SECG curve over a 256 bit prime field ﬁ‘ % x
|| add |

= Elliptical Curves:
» Build a list of acceptable Elliptical Curve algorithms (RFC 4492)
» Allows equivalent security to current cryptosystems like RSA but smaller key size
» Favored for mobile technology

R
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Back to the
Queue Manager Object
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Queue Manager — CCSI Tab

Coded Character Set ID [a19

Convert Input

= Coded Character Set ID
» Presented to the SYRCONN channel during connection
» Same as setting MQCCSID Environment Variable

= Convert Input
» On: Ask the Queue Manager to convert messages using the CCSID (default)
» Off: No conversion

T —
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Queue Manager — MQCSP Tab

E

Connections £EesI MQCSP

IBM MQ Queue Manager: DEVQMGR. [up]

| Apply |[ cancel || Delete |[ Undo |

MQCSP User ID [Tt

MQCSP Password Alias [admin ¥ |[+ [ .. ]*
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Queue Manager — MQCSP Tab

= Defines the MQCSP Data Structure
» Simulates passing MQCSP using MQCONNX

= MQCSP User ID
» Sent via MQCSP if present
» If blank (and Password Alias set to “none”), no MQCSP is sent

= MQCSP Password Alias
» Points to the encrypted password stored within DataPower
» Password is sent in clear text in MQCSP after retrieval from the Alias

T —
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MQ Front Side Handler Object
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MQ Front Side Handle

General

Administrative state & enabled . disabled

Comments

Qs Manupe [oEvqmer v [+ .. |*

Get Queue f_DPIN *
Put Queue DpQU-r i
The number of concurrent 1IBM MQ .'1

conversations

Get Message Options | 1

Palling Interval | '3'0_ 1 seconds
Retrieve Backout Settings s on @) off

Use Queue Manager in URL on (@ off

ccsl1 o

I —
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MQ Front Side Handler

= Get Queue

» Name of queue to get messages from

» Mandatory, unless Pub/Sub being used
= Put Queue

» Optional, because:

* May be "one-way" messaging (fire and forget)

e May be using Reply-To Queue

® May be dynamically allocated by Response Rule code
= The number of concurrent MQ conversations:

» Number of parallel active and pending MQGETSs for the Get Queue
Recommend value of 1 (in high throughput situations, may use up to 5)
Regardless of this setting, multiple FSH threads will still use multiple connections
If greater than 1, monitor Queue Manager for workload
If greater than 1, Backout Threshold must be this value plus 1
If using message ordering (MQGMO_LOGICAL_ORDER), set it to 1

vVvyVvyVvyy
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MQ Front Side Handler

= Get Message Options
» Allows the use of any MQGMO_Options parameters
» Overrides any specific parameters set elsewhere
= Polling Interval
» How long to wait on an empty queue (seconds)
» Equivalent to Wait Interval with conventional MQ applications
> Low value increases network traffic
» Recommend default of 30
= Retrieve Backout Settings
» Get BOTHRESH and BOQUEUE from the Get Queue
> Issues MQINQ before every MQGET — potential performance hit
» Only relevant if queue parameters were set by MQ administrator
» Recommend set "off" and use Queue Manager Object settings

[ —
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Some MQGMO Options

0 MQGMO_NONE

1 MQGMO_WAIT

2 MQGMO_SYNCPOINT

4 MQGMO_NO_SYNCPOINT

8 MQGMO_SET SIGNAL

16 MQGMO_BROWSE_FIRST

32 MQGMO_BROWSE_NEXT

64 MQGMO_ACCEPT_TRUNCATED_MSG
128 MQGMO_MARK_SKIP_ BACKOUT
256 MQGMO_MSG_UNDER_CURSOR
512 MQGMO_LOCK

1024 MQGMO_UNLOCK

2048 MQGMO_BROWSE_MSG_UNDER_CURSOR
4096 MQGMO_SYNCPOINT_IF_PERSISTENT
8192 MQGMO_FAIL IF_QUIESCING

16384 MQGMO_CONVERT

32768 MQGMO_LOGICAL _ORDER

65536 MQGMO_COMPLETE_MSG

131072 MQGMO_ALL_MSGS_AVAILABLE

262144 MQGMO_ALL_SEGMENTS_AVAILABLE
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MQ Front Side Handler

= Use Queue Manager in URL
» Defines the behavior of var://service/lURL-in when a QM Group is specified
» If on, the variable returns the name of the chosen Queue Manager
» If off, the variable returns the name of the Queue Manager Group
» Default off

= CCsl
» Sets the CCSID in the MQ Message Descriptor
» If blank or zero, default is 1SO-8859-1 (latin-1)
» For MQCCSI_EMBEDDED enter 4294967295
» For MQCCSI_INHERIT enter 4294967294

T —
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MQ Front Side Handler

Publish and Subscribe

Subscribe Topic String
Subscription Name

Publish Topic String

Properties and Headers

Parse Properties @ on ( off
Selector
Exclude Message Headers " c1CSs Bridge Header (MQCIH)

!/ Dead Letter Header (MQDLH)

1/ IMS Information Header (MQIIH)

" Rules and Formatting Header (MQRFH)
I/ Rules and Formatting Header (MQRFH2)
) work Information Header (MQWIH)

Header to extract Content-Type None X
Advanced

Async Put on (e off
Batch Size 0
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MQ Front Side Handler

= Subscribe Topic String
» Pub/Sub topic string for subscription
> If Get Queue also defined, this is ignored
= Subscription Name
» Used to establish or resume a Durable Subscription

Publish Topic String
» Pub/Sub topic string for response publication
» If Put Queue also defined, this is ignored
= Parse Properties
» Extracts MQ V7 (and above) Message Properties into Node Set
» Minor overhead, so leave off unless needed

T —
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MQ Front Side Handler

= Selector
> Allows selective retrieval of messages based on properties
» Forces sequential search of queue so may be inefficient
= Exclude Message Headers
» Strip off selected MQ header types
= Header to extract Content-Type
» Can obtain Content-Type from

° MQMD Header to extract Content-Type |ﬂ1—P‘FH2 ¥ |

® RFH *Path expression to extract Content-Type ¥Path Tool- *
from IBM MQ header o

* RFH2
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MQ Front Side Handler

= Async Put
» Put message to queue without waiting for a response
» Do not use when Queue Manager units-of-work is 1
» Recommend only use where performance is an issue

= Batch Size
» Number of messages to handled as a singe commit or rollback operation
» Recommend leave this as zero — each message is a separate transaction

[ —
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MQ Back-End URL
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MQ Back-End URL

General Syntax:
» dpmg://mgQueueManagerObject/URI?<parameters>

RequestQueue=requestQueueName
» Name of the backend MQ request queue

ReplyQueue=replyQueueName
» Name of the backend MQ reply queue

Sync=true
> Issues a Commit call when a message is put on Request Queue

GMO=optionsValue
» MQGMO_Options parameter value when getting from Reply Queue

PMO=optionsValue
» MQPMO_Options parameter value when putting to Request Queue

Capitalware's MQ Technical Conference v2.0.1.6
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MQ Back-End URL

= ParseHeaders={true|false}
» Specifies whether to parse and strip headers from message

= SetReplyTo={true|false}
» Specifies whether to set MD ReplyToQ during Put

= AsyncPut={true|false}
» Specifies whether to use Asynchronous Put
» Only valid when using MQ V7 (and above)

= Browse={first|next|current}
» Controls non-destructive retrieval of messages

41
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MQ Back-End URL

= ContentTypeHeader=header
» Which MQ header identifies the content type of the message

= ContentTypeXPath=expression
» XPath expression to extract the content type of message

= ParseProperties={on|off}
» Parse message properties

= PublishTopicString=string and SubscribeTopicString=string
» Specifies topic to use with Pub/Sub (MQ V7 and above)

= SubscriptionName=string
» Specifies name for a durable subscription (MQ V7 and above)

= Selector=expression
» SQLI2 style query filtering on message properties
» Performance hit

e —

Capitalware's MQ Technical Conference v2.0.1.6

21



Multi-Protocol Gateway
Parameter Settings
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MPGW Headers Tab — MQ Headers

(4}ions Policy SLA Policy Details Stylesheet Params Headers Monitors Ws-addressing WS-ReliableMessaging ) (=

Export | View Log | View Status | Show Probe | Validate Conformance | Help

Apply  Cancel Delete

Multi-Protocol Gateway status: [up]

Header Injection Parameters

Direction Header Name Header Value

Add

Header Suppression Parameters

Direction Header Tag

Add

N —
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MPGW Headers Tab — MQ Headers

Add a New Header Injection Parameter

Direction :Front ".. | *
Header Name [ | *
Header Value . | #

Submit | Cancel

= Using Header Injection (Header Tab)

= Example setting Format and Persistence:
» Direction: Front (for FSH MQPUT)
» Direction: Back (for Backend MQPUT)
» Header Name: MQMD

» Header Value:
<MQMD><Format>MQSTR</Format><Persistence>1</Persistence></MQMD>

45
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MQ Programmatic Control

B e
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MQ Headers — Programmatic Manipulation

= Using the Stylesheet method (page 1 of 2)

<?xml version="1.0" encoding="UTF-8"?>

<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.0rg/1999/XSL/Transform"
xmlns:dp="http://www.datapower.com/extensions"
extension-element-prefixes="dp"
exclude-result-prefixes="dp">

<xsl:output method="xml"/>
<xsl:template match="/">
<xsl:variable name="newMQMDStr">
<MQMD>
<Format>MQSTR</Format><Persistence>1</Persistence>
</MQMD>
</xsl:variable>
<xsl:variable name="mgmdStr">
<dp:serialize select="$newMQMDStr" omit-xml-decl="yes"/>
</xsl:variable>
<xsl:message dp:priority="debug">
<xsl:value-of select="concat('The New MQMD : ', $mgmdStr)"/>

47
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MQ Headers — Programmatic Manipulation

= Using the Stylesheet method (page 2 of 2)

</xsl:message>

<!-- for request rule -->

<dp:set-request-header name="'MQMD'" value="$mgmdStr"/>

<!-- for response rule -->

<!-- <dp:set-response-header name="'MQMD'" value="$mgmdStr"/> -->
<!-- adding MQ header when MQ URL open call is usedfor MQPUT-->
<l--

<xsl:variable name="mgHeaders">
<header name="MQMD"><xsl:value-of select="$mgmdStr"/></header>
</xsl:variable>
<xsl:variable name="sendmessage">
<dp:url-open
target="dpmq://DP4/?RequestQueue=QUEUEG"
http-headers="$mgHeaders"
responsecode-ignore">
<xsl:copy-of select="." />
</dp:url-open>
</xsl:variable>

—nu

response=

S
</xsl:template>
</xsl:stylesheet>

|
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MQ Headers — Programmatic Manipulation

= Context variable method to inject the MQMD header
» For the following code to work:
» Set Transform Action's OUTPUT context to "EVENTS"
> Set Result Action's INPUT context to "EVENTS"

<xsl:variable name="MQMDStr">
<MQMD>
<Expiry>8000</Expiry>
<Priority>0</Priority>
<Format>MQSTR</Format>
</MQMD>
</xsl:variable>
<xsl:variable name="MQMDStr2">
<dp:serialize select="$MQMDStr" omit-xml-decl="yes"/>
</xsl:variable>
<dp:set-variable name="'var://context/EVENTS/_extension/header/MQMD'"
value="$MQMDStr2"/>

49
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MQ Headers — Programmatic Manipulation

= JMS Headers as Message Properties
» Must set FSH “Parse Properties” to be “on”
» Must set “Exclude RFH2” to be “off”
» Message Properties appear as “MQMP” header

Protocol Headers:

<MQMD==<5Strucld=MD </Strucld><Version>1</Version=<Report=0</Report=<MsgType>8</MsgType>
<Expiry=-1</Expiry><Feedback>0</Feedback><Encoding>546</Encoding>
<CodedCharSetld=819=/CodedCharSetld=<Format=MQSTR </Format=><Priarity >d=/Priority =
<Persistence=1</Persistence><Msgld>414d5120444556514d47522020202020963775722087c02=/Msgld=
<CorrelId=000000000000000000000000000000000000000000000000</Correlld=<BackoutCount=0</BackoutCount>
MQMD <ReplyToQ= =/ReplyToQ=<ReplyToQMar=DEVQMGR =/ReplyToQMar=<Userldentifier=virtuser </Userldentifier>
<AccountingToken=16010515000000dd7a5d8bea372ba8al058899e803000000000000000000000b</AccountingToken=
<ApplidentityData= </ApplldentityData=<PutApplType=11</PutAppliType=
<PutspplName=C:\Windows\System32\java.exe</PutApplName = <PutDate=20160926=/PutDate=
<PutTime=20093683</PutTime><ApplOriginData> </ApplOriginData=</MQMD=>

[View Parsed]

<MQMP=<Property name="mcd.Msd" type="string">jms_text</Property ><Property name="jms.Dst"
type="string"=queue://DEVQMGR/DPIN=/Property =<Property name="jms.Tms"
type="string">1474920576830</Property > <Property name="jms.DIv" type="string">2</Property>=</MQMP>=

e —
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MQ Headers — Programmatic Manipulation

= JMS Headers as RFH2
» Must set FSH “Parse Properties” to be “off”
» Must set “Exclude RFH2” to be “on”
» Message Properties appear as “MQRFH2” headers

X-MOQRFH2-

Data-0 <mcd=<Msd=jms_text=/Msd=</mecd=

;;TS ?FH 2- =jms=><Dst>queue://DEVQMGR/DPIN=/Dst>=Tms>1474922529242 < /Tms>=<Dlv=2</Dlv > </jms>

<MQRFH2=<Strucld=RFH </Strucld=<Version=2</Version=<Encoding=546</Encoding>
<CodedCharSetld=819=/CodedCharSetld=<Format=MQSTR </Format=<Flags=0</Flags=>
<NameValueCCSID>1208</NameValueCCSID>=<NameValueData=<NameValue><mecd=<Msd=jms_text</Msd=

MQRFH2 </med> </NameValue><NameValue><jms><Dst=queue://DEVQMGR/DPIN=</Dst><Tms>1474922529242</Tms>
=Dly=2</Dlv=</ims> =/NameValue=</NameValueData>=/MQRFH2 >

51
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MQ Error Handling

= MQ error handling example:

<xs5l:template match="/">
<xsl:variable name="mgrc" select="dp:response-header('x-dp-response-code')"/>
<xslivariable name="ecode" select="dp:variable('var://service/error-code')"/>
<xsl:variable name="errMsg" select="concat('** The Response Code ** : ', $mqrc, ' and ** Error
Code ** :', Secode )"/>

<xsl:choose>
<xsl:when test="(starts-with($mgrc, '2') and (string-length(normalize-space(Smgrc))= 4)) or
($ecode != 'oOxpoooopoe')">
<xsl:message dp:priority="debug">
<xsl:value-of select="SerrMsg"/>
</xsl:imessage>
<dp:set-variable name="'var://context/ERROR/err-msg'" value="SerrMsg"/>
<dp:reject override="true"><xsl:value-of select="SerrMsg"/></dpireject>
</%sl:when>
<xsl:otherwise>
<xsl:message dp:priority="debug"=>
<xsl:value-of select="$errMsg"/>
</xsl:message=
<dp:accept/>
</xsl:otherwise>
</xsl:choose>
</xsl:template=

T —
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MQ Conversational Processing

= Backend application must copy Msgld to Correlld
» DataPower Back-End retrieves reply using Correlld

= MQPUT1 Simulation
» Create MQ Object Descriptor header with Queue Manager name in it
» Request Rule issues MQOPEN/MQPUT/MQCLOSE to back end Queue Manager

= ReplyToQ Usage
> If set, Response Rule sends message there

= ReplyToQmgr Usage
» Can be set to send to a different Queue Manager
» If destination is a Cluster, no need to supply ReplyToQmgr
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MQ Conversational Processing

= XSL code snippet to set ReplyToQ and ReplyToQmgr in a Request Rule:

<xsl:variable name="rule-type" select="dp:variable('var://service/transaction-rule-type')"/>
<xsl:choose>
<!-- Request Rule only -->
<xsl:when test="$rule-type = 'reguest'">
<xslivariable name="entries" select="dp:reguest-header('MQMD"')"/>
<xsl:variable name="header" select="dp:parse($entries)"/>
<!-- save ReplyToQ and ReplyToQMgr values -->
<dp:set-variable name="'var://context/MYMQMD/ReplyToQ'" value=""$header//ReplyToQ"/>
<dp:set-variable name="'var://context/MYMQMD/ReplyToQMgr'" value=""Sheader//ReplyToQMgr"/>
<xslimessage dp:priority="debug">
<xsl:value-of select="concat ('Request MQMD : ', dp:request-header('MQMD'))"/>
</xsl:message=
</xs)l:when>
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MQ Conversational Processing

= XSL code snippet to set ReplyToQ and ReplyToQmgr in a Response Rule:

<|-- Response rule only --=
<xsl:when test="$rule-type = 'response'">
<xsl:variable name="custMQODStr"=
=<MQOD=
<Version=2</Version>
<0bjectiame=
<xslivalue-of select="dp:variable('var://context/MYMQMD/ReplyToQ')"/>
</0bjectName>
<0bjectQMgrhame>

<xslivalue-of select="dp:variable{'var://context/MYMQMD/ReplyToQMgr')"/=
</0bjectQMgrName>
</MQOD=>
</xsl:variable>
<xsl:variable name="mgodStr">
<dp:serialize select="$custMQDDStr" omit-xml-decl="yes"/>
</xsl:variable>
<xsl:message dp:priority="debug">
<xsl:value-of select="concat('Response MQOD : ', S$mgodStr)"/>
</xsl:imessage>
<dp:set-response-header name="'MQOD'" value="$mqodStr"/>
</xsl:when>
</xsl:choose>
</xsl:template>
</xslistylesheet>
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Transactional Processing
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MQ Transactional Processing

= DataPower is a standard MQ Client
> It does NOT offer Extended Transactional Client functionality
» NO XA two-phase commit
= DataPower is considered an application by MQ
» Therefore, no inherent message integrity
= |f the same Queue Manager at front and back:
» True message integrity
» Once and once-only delivery
= [f different Queue Managers at front and back
» No possibility of two-phase commit
» Message integrity assured if DataPower configured properly
» Possibility of messages sent more than once
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Scenario: Two Different Queue Managers

No Transactional Control

Sync=false;
T | Units of Work =0 Transactional=false
Queue Queue
N Manager Manager
QM1 Qm2

DataPower

Request Rule

K Response Rule

—<
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Scenario: Two Different Queue Managers

Front Side Transactional Control only

| Units of Work =1

Sync=false;
Transactional=false T /

Queue
N Manager
QM1

Queue
Manager
QM2

DataPower

Request Rule

>// /I

Response Rule
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Scenario: Two Different Queue Managers

Back End Transactional Control only

| Units of Work =0

Sync=false;

Transactional=true

Queue
N Manager
QM1

Queue
Manager
QM2

DataPower

Request Rule

>//

—1\\

Response Rule

60

Capitalware's MQ Technical Conference v2.0.1.6

30



Scenario: Two Different Queue Managers

Front Side and Back End Transactional Control

Sync=false;
| Units of Work =1 Transactional=true /

Queue Queue
N Manager Manager
QM1 QM2

DataPower
Y Request Rule
K Response Rule Y
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Scenario: One Queue Manager (Front & Back)

No Transactional Control

Sync=false;
| Units of Work =0 Transactional=false

* * Queue Manager QM1

DataPower
1 4
Request Rule
K Response Rule

—1\\
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Scenario: One Queue Manager (Front & Back)

Front Side Transactional Control only

Sync=false;
| Units of Work =1 Transactional=fals /

* * Queue Manager QM1

DataPower
Y Request Rule
K Response Rule Y
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Scenario: One Queue Manager (Front & Back)

Front Side Transactional Control only

| Units of Work =1 Transactional=false

* * Queue Manager QM1

DataPower
1 4
Request Rule
K Response Rule

—1\\
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Scenario: One Queue Manager (Front & Back)

Front Side and Back End Transactional Control

Sync=true;
| Units of Work =1 Transactional=true /

* * Queue Manager QM1

DataPower
Y Request Rule
K Response Rule Y
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Poison Message

BOQUEUE = FS.ERR

[ At ] BOTHRESH = 3

[rssan | [ ran Queue Manager QM1

A
1 Units of Work = 1

DataPower

FSH Request Rule
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Poison Message

[ At ] BOTMmEal = 3
| BOQUEUE =F3»
- Ah Queue Manager QM1
1 Units of Work = 1
1
DataPower
FSH

Request Rule
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DataPower Knowledge Center Documentation

https://www.ibm.com/support/knowledgecenter/en/SS9H2Y 7.5.0/
com.ibm.dp.doc/retrieve-backout-setting mgfsh.html

Poison Message
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Questions & Answers

Capitalware's MQ Technical Conference v2.0.1.6

End of Session

Thank You!

Contact: Robin@RobinWileyTraining.com

Handouts: RobinWileyTraining.com/MQTC2016
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